Notifications/Browser Notifications

Joined
Aug 1, 2020
Call it part request, part question, part bug report I guess?

Not sure if it is us, but we get no notifications without manually refreshing the page, and browser notifications do not work at all. The only reason I really know that's a thing, is we were part of another forum that uses the same software and both update automatically, not sure if it's a version thing, or if they're just broken, or if it's something on our end (though they worked just fine on the other forum so not sure). But curious, that would be a feature I would love to see implemented or fixed if possible.
 

Sky Reed

Administrator
Staff member
Joined
Jan 1, 2019
Location
Under Your Bed
When you click your name above, you will see the drop-down menu under your name, there is the preference under Your Account, you can click all the alerts you want to receive via email. I don't think it's a bug. Unless your browser is blocking your alerts. This is, after all, an adult site so it might block some stuff on your browser so check your cookies to see if you check it to be safe.
 
Joined
Aug 1, 2020
We don't want email notifications. We only check our email once or twice a day. We get the little red square with the number in it at the top of the page when we have an alert, but the other site, the title bar would give you a little (1) to tell you that you have notifications, and I don't get those here. But I haven't gotten any pop up or anything asking about browser notifictations, I just don't get those here, and I'm not sure why.
 

Sky Reed

Administrator
Staff member
Joined
Jan 1, 2019
Location
Under Your Bed
I wish I could help but before I was using chrome and it suddenly block this site so I switched to firefox I guess I need to update or redo my pop-up blockers. But I don't know if there would be more experienced people who can reply to you about that but just wait and maybe another admin have better answer for you :)
 
Joined
Aug 1, 2020
I'll do some more looking on my end too just to be safe. I cleared cache and cookies and all that, double checked my settings on the forum. We use firefox, but they don't work properly on firefox or chrome from what we've seen at least for us.
 
Joined
Aug 1, 2020
6951
Just for clarification to be safe, these are what we're talking about. We get them after a manual refresh, but on the other forum those notifications would go through automatically without having to manually refresh the page.
 

Sky Reed

Administrator
Staff member
Joined
Jan 1, 2019
Location
Under Your Bed
Do you have numerous tabs open too? but you are right about that part, I got some rp open when I am writing, and then the home page all in the same page different tabs, so while am typing someone replied to me, I would get that number on the page where I am typing so I know I got a reply. But with mine, I don't need to refresh my page. I don't know what you need to check because I am using firefox all my pop blockers have added FD as safe and if I get logged off it would only ask me that this site uses cookies and if I accept them. So there got to be something that is blocking FD on your end somehow. So you only use push notification or email too? Where does your email from FD go? Mine sometimes goes to my bulk mail so I don't get alerts when it does that sometimes.
 
Joined
Aug 1, 2020
If you get notifications it must be on my end, I'll turn off the ad blocker for FD and see if that helps, thank you.
 

ZetaInfection

Member
Joined
Jan 4, 2019
I’m late to the party but I noticed this too. On other RP sites using Xenforo you can leave the tab open and as soon as you get a notification you will see it in the tab title as like (1) and you don’t even have to be tabbed into that tab to see it. That doesn’t appear to be a thing on Fiction Depot and is one of the things I find inconvenient here, among a few other nitpicks. It’s nice to be able to browse the web without worrying about missing a notification but on this site you absolutely have to refresh the page to see any notifications.

I am no pro but I kinda want to say it might be a setting on the admin’s side that may not be enabled? I can’t think of any other reason this happens here and not elsewhere and I use ad blocker by default. It should have nothing to do with ad blocker since it works elsewhere. >.>
 
Joined
Aug 1, 2020
After doing a bit of searching, we are actually wondering if it is just an older version of the forum software or perhaps additional plugins of some sort that are there and not here. One reason that makes us believe so, is on another forum that uses it, with the conversations page up, on the left where the user icons are for whoever started the conversation, there would be a mini icon on top of it for the last person to post, in addition to it being listed on the right side of the page. It was a small note, but it did make it 'visually' faster and simpler to know who had last responded.

No points that we can't deal with mind you, just commenting on the whats and whys. Those are the only two points that we are aware of off hand that we 'notice' just as a user of the site, but, they were nice conveniences to have.

I have found however, that using an auto-refresh plugin for the site does not update the task bar title/tab so manual refreshes of the page are required, that is a little annoying, but we're getting used to it.
 
Top Bottom